maschinenkrueger.com

Site News => Forum News => Topic started by: FBek on November 11, 2020, 01:43:37 PM



Title: Browser message - "Your connection to this site is not secure"
Post by: FBek on November 11, 2020, 01:43:37 PM
Why am I seeing a warning message 'Your connection to this site is not secure' @ the browser address line? It wasn't the case before but I can't recall when it started.

Anything to worry about?  ???


Title: Re: Browser message - "Your connection to this site is not secure"
Post by: futch on November 11, 2020, 05:13:37 PM
Forum is hosted on a http: site, not https:. Since a login is involved, your browser is probably just warning you. If youre behind a router at home you're generally ok from 'snoopers'. If you login with a public computer, or public wi-fi, then best your forum password doesnt match your internet banking password  :D


Title: Re: Browser message - "Your connection to this site is not secure"
Post by: futch on November 11, 2020, 05:15:49 PM
Somewhere your browser settings, there should be a 'Trusted Websites' area (or something like that). If you add this forums addy, the warning should go away. Alternatively, some newer browsers let you click in the address bar and add the site that way.


Title: Re: Browser message - "Your connection to this site is not secure"
Post by: ehrel on November 12, 2020, 07:59:10 AM
There's an add-on called "HTTPS everywhere" - it generally solves this issue when on http sites


Title: Re: Browser message - "Your connection to this site is not secure"
Post by: FBek on November 12, 2020, 10:10:14 AM
Futch: noted. Ehrel: I've added "HTTPS everywhere" to Chrome and it works.
I'm still not sure why Chrome was able to deal with this issue at times, and flag a warning at others - but that's resolved for now.

Thanks


Title: Re: Browser message - "Your connection to this site is not secure"
Post by: futch on November 12, 2020, 02:23:48 PM
Futch: noted. Ehrel: I've added "HTTPS everywhere" to Chrome and it works.
I'm still not sure why Chrome was able to deal with this issue at times, and flag a warning at others - but that's resolved for now.

Thanks

...Chrome probably trying to phone home to Google and finding out we're not white listed...while other websites are.

MaK is the dark web !


Title: Re: Browser message - "Your connection to this site is not secure"
Post by: theBaron on November 12, 2020, 05:50:17 PM
Did it just start recently?  Do you know if you got browser updates around the same time?  If this happened after you got browser updates, it could be that one of the updates changed how the browser handles non-secure content.  As you've found, the solutions people suggested take care of it.  I just wanted to offer a possible explanation of why it happened.  I see it come and go, depending on the browser, and also, depending on changes the developers of any given website make.  I manage it via browser settings, as Futch first mentioned, rather than downloading and installing any add-ons.


Title: Re: Browser message - "Your connection to this site is not secure"
Post by: FBek on November 13, 2020, 08:23:15 AM
It is probably centered around browser updates over time but I can't really be sure. I use latest Chrome, on both laptop and phone, and keep them updated.
I installed the add-on as I could not find any setting to get the browser to 'trust' the website - maybe I've looked in the wrong places; and I'm still looking..

Just to be clear, the browser did not block the site; it just added a warning sign & message, instead of the padlock sign, at the start of the address line.


Title: Re: Browser message - "Your connection to this site is not secure"
Post by: rancor1223 on November 13, 2020, 10:26:40 AM
Likely a change of policy in how the browser handles HTTP sites. With how ubiquitous HTTPS has become (since you can now get it free trough Let's Encrypt), it's becoming more or less standard. With that said, Firefox is not complaining, yet.


Title: Re: Browser message - "Your connection to this site is not secure"
Post by: theBaron on November 13, 2020, 06:10:37 PM
...Just to be clear, the browser did not block the site; it just added a warning sign & message, instead of the padlock sign, at the start of the address line.

Understood.  What I've seen frequently is that with mixed content (secure and unsecure), the browser can't render a page correctly, till I adjust settings to allow unsecure content.  Depending on the website, it can be a subtle effect, or it could be that style elements aren't rendered correctly, and everywhere in between.

I'm reminded now of "Robot Chicken's" spoof of "Tron", both the movie and the video game.  As the Main Control Program is under assault, it says, "Computers will rule humans one day!  Well, maybe they won't rule humans, just really annoy them!"