December 02, 2020, 07:15:51 AM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Ma.K.n' it since 2007!
 
   Home   Help Login Register  
Pages: [1]
  Print  
Author Topic: Browser message - "Your connection to this site is not secure"  (Read 357 times)
FBek
Ma.K. Enthusiast
***
Posts: 142



WWW
« on: November 11, 2020, 07:43:37 AM »

Why am I seeing a warning message 'Your connection to this site is not secure' @ the browser address line? It wasn't the case before but I can't recall when it started.

Anything to worry about?  Huh
Logged
futch
Administrator
Ma.K. Spammer
*
Posts: 5103



WWW
« Reply #1 on: November 11, 2020, 11:13:37 AM »

Forum is hosted on a http: site, not https:. Since a login is involved, your browser is probably just warning you. If youre behind a router at home you're generally ok from 'snoopers'. If you login with a public computer, or public wi-fi, then best your forum password doesnt match your internet banking password  Cheesy
Logged

Homepage: futchFactor.com FaceBook/Skype: Futch Factor
futch
Administrator
Ma.K. Spammer
*
Posts: 5103



WWW
« Reply #2 on: November 11, 2020, 11:15:49 AM »

Somewhere your browser settings, there should be a 'Trusted Websites' area (or something like that). If you add this forums addy, the warning should go away. Alternatively, some newer browsers let you click in the address bar and add the site that way.
Logged

Homepage: futchFactor.com FaceBook/Skype: Futch Factor
ehrel
Ma.K. Enthusiast
***
Posts: 121


that's a nicely curved armour skirt


Email
« Reply #3 on: November 12, 2020, 01:59:10 AM »

There's an add-on called "HTTPS everywhere" - it generally solves this issue when on http sites
Logged

Il semble que la perfection soit atteinte non quand il n'y a plus rien à ajouter, mais quand il n'y a plus rien à retrancher.
FBek
Ma.K. Enthusiast
***
Posts: 142



WWW
« Reply #4 on: November 12, 2020, 04:10:14 AM »

Futch: noted. Ehrel: I've added "HTTPS everywhere" to Chrome and it works.
I'm still not sure why Chrome was able to deal with this issue at times, and flag a warning at others - but that's resolved for now.

Thanks
Logged
futch
Administrator
Ma.K. Spammer
*
Posts: 5103



WWW
« Reply #5 on: November 12, 2020, 08:23:48 AM »

Futch: noted. Ehrel: I've added "HTTPS everywhere" to Chrome and it works.
I'm still not sure why Chrome was able to deal with this issue at times, and flag a warning at others - but that's resolved for now.

Thanks

...Chrome probably trying to phone home to Google and finding out we're not white listed...while other websites are.

MaK is the dark web !
Logged

Homepage: futchFactor.com FaceBook/Skype: Futch Factor
theBaron
Ma.K. Spammer
*****
Posts: 1745



Email
« Reply #6 on: November 12, 2020, 11:50:17 AM »

Did it just start recently?  Do you know if you got browser updates around the same time?  If this happened after you got browser updates, it could be that one of the updates changed how the browser handles non-secure content.  As you've found, the solutions people suggested take care of it.  I just wanted to offer a possible explanation of why it happened.  I see it come and go, depending on the browser, and also, depending on changes the developers of any given website make.  I manage it via browser settings, as Futch first mentioned, rather than downloading and installing any add-ons.
Logged
FBek
Ma.K. Enthusiast
***
Posts: 142



WWW
« Reply #7 on: November 13, 2020, 02:23:15 AM »

It is probably centered around browser updates over time but I can't really be sure. I use latest Chrome, on both laptop and phone, and keep them updated.
I installed the add-on as I could not find any setting to get the browser to 'trust' the website - maybe I've looked in the wrong places; and I'm still looking..

Just to be clear, the browser did not block the site; it just added a warning sign & message, instead of the padlock sign, at the start of the address line.
« Last Edit: November 13, 2020, 11:56:34 AM by FBek » Logged
rancor1223
Ma.K. Fan
**
Posts: 50


Email
« Reply #8 on: November 13, 2020, 04:26:40 AM »

Likely a change of policy in how the browser handles HTTP sites. With how ubiquitous HTTPS has become (since you can now get it free trough Let's Encrypt), it's becoming more or less standard. With that said, Firefox is not complaining, yet.
Logged
theBaron
Ma.K. Spammer
*****
Posts: 1745



Email
« Reply #9 on: November 13, 2020, 12:10:37 PM »

...Just to be clear, the browser did not block the site; it just added a warning sign & message, instead of the padlock sign, at the start of the address line.

Understood.  What I've seen frequently is that with mixed content (secure and unsecure), the browser can't render a page correctly, till I adjust settings to allow unsecure content.  Depending on the website, it can be a subtle effect, or it could be that style elements aren't rendered correctly, and everywhere in between.

I'm reminded now of "Robot Chicken's" spoof of "Tron", both the movie and the video game.  As the Main Control Program is under assault, it says, "Computers will rule humans one day!  Well, maybe they won't rule humans, just really annoy them!"
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!